Back to overview
Maintenance
Analytics aggregation maintenance
May 19, 2026 at 4:00pm UTC
–
May 20, 2026 at 8:00am UTC
Affected services
Analytics Aggregation
Resolved
May 20, 2026 at 8:00am UTC
Maintenance ended
Affected services
Created
May 19, 2026 at 4:00pm UTC
Our analytics aggregation processor is undergoing essential maintenance. This will have no impact to our services and no data loss will occur.
Affected services